主力状态(通达信公式 副图 源码 测试图)(图文)

时间:2020-04-13 10:38:21 作者:admin
后台-系统-系统设置-扩展变量-(内容页告位1-手机版)

波段看盘的辅助指标,此指标主要是方便战法选出来的标的辅助看盘之用。对股性有要求,不是随便逮到一只票就能做波段的!

{公式名称: 主力状态

公式描述: 

参数数量: 5

参数1: N, 最小: 1, 最大: 300, 缺省: 35

参数2: M, 最小: 1, 最大: 500, 缺省: 35

参数3: N1, 最小: 1, 最大: 1000, 缺省: 1

参数4: NX, 最小: 0, 最大: 122, 缺省: 42

参数5: N1X, 最小: 0, 最大: 122, 缺省: 21

公式类型: 技术指标公式-其他类型

画线方法: 副图

公式版本: 0

显示小数: 缺省位数

坐标线位置: 自动

额外Y轴分界: 无

 

参数精灵:

请设置计算参数:

N: Param#0 (1.00--300.00)

M: Param#1 (1.00--500.00)

N1: Param#2 (1.00--1000.00)

NX: Param#3 (0.00--122.00)

N1X: Param#4 (0.00--122.00)

用法注释:无

公式源码:}
 

XA_1:=IF(CLOSE<OPEN,(CLOSE-OPEN)/OPEN,0);

XA_2:=IF(CLOSE>OPEN,(CLOSE-OPEN)/OPEN,0);

XA_3:=IF(CLOSE>OPEN,(OPEN-LOW)/OPEN,(CLOSE-LOW)/OPEN);

XA_4:=IF(CLOSE>OPEN,(HIGH-CLOSE)/OPEN,(HIGH-OPEN)/OPEN);

XA_5:=IF(BARSLAST(CLOSE>MA(CLOSE,20))>34,34,BARSLAST(CLOSE>MA(CLOSE,20)));

XA_6:=IF(BARSLAST(CLOSE>MA(CLOSE,60))>120,120,BARSLAST(CLOSE>MA(CLOSE,60)));

XA_7:=IF(COUNT(CLOSE>0,250)<240,CAPITAL,SUM(VOL,480)/8);

XA_8:=MA(LOW,20)*1.2;{分析家公式网 }

XA_9:=MA(LOW,20)*1.1;

XA_10:=MA(HIGH,20)*0.9;

XA_11:=MA(HIGH,20)*0.8;

XA_12:=CLOSE/(1+(CLOSE/MA(CLOSE,240)-1)-MA(INDEXC/MA(INDEXC,240)-1,3));

短线上攻:IF(BARSLAST(CLOSE>XA_9)<4 AND CLOSE>MA(CLOSE,5) AND BARSLAST(CLOSE=HHV(CLOSE,21))<4,(MA(CLOSE,5)-REF(MA(CLOSE,5),1))/REF(MA(CLOSE,5),1)*300,0),COLORMAGENTA;

中线强势:(CLOSE/XA_12-1)*50,COLORRED,LINETHICK2;

中线控盘:MA(IF(CLOSE>MA(CLOSE,240) AND (CLOSE-MA(CLOSE,240))/MA(CLOSE,240)+SUM(XA_1,20)>0,((CLOSE-MA(CLOSE,240))/MA(CLOSE,240)+SUM(XA_1,20))/MA(VOL/XA_7,20)/2.5,0),10),COLORYELLOW,LINETHICK2;

短线超跌:IF(CLOSE<MA(CLOSE,20),((REF(CLOSE,XA_5)-CLOSE)/REF(CLOSE,XA_5)+SUM(XA_3,XA_5)-SUM(XA_4,XA_5))*20,0),COLORBLUE,LINETHICK2;

中线超跌:(REF(CLOSE,XA_6)-CLOSE)/CLOSE*2,COLORGREEN,LINETHICK2;

STICKLINE(中线强势>0,0,中线强势,0.7,0),COLORRED;

STICKLINE(中线控盘>0,0,中线控盘,0.7,0),COLORYELLOW;

STICKLINE(短线上攻>0,0,短线上攻,0.7,0),COLORMAGENTA;

STICKLINE(中线超跌>0,0,中线超跌,0.7,0),COLORGREEN;

STICKLINE(短线超跌>0,0,短线超跌,0.8,0),COLORBLUE;

 

 

 

 

 


后台-系统-系统设置-扩展变量-(内容页告位2-手机版)
声明:本文内容由互联网用户自发贡献自行上传,本网站不拥有所有权,未作人工编辑处理,也不承担相关法律责任。如果您发现有涉嫌版权的内容,欢迎发送邮件至本站联系邮箱进行举报,并提供相关证据,工作人员会在5个工作日内联系你,一经查实,本站将立刻删除涉嫌侵权内容。
后台-系统-系统设置-扩展变量-(内容页告位3-手机版)